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 Introduction 

This application note provides users with application guidance for using Eclipse to develop 

APM32 series MCU under Windows system. 
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 Development environment 

• Development board: APM32F103ZEMINI development board 

• Debugger: J-Link V9/V10 or Geehy-Link 

• Operating system: WIN10 64 bit OS 

• IDE：Eclipse IDE for Embedded C/C++ Developers Version: 2022-03 (4.23.0) 

• Cross compilation chain: gcc-arm-none-eabi-10.3-2021.10-win32.exe 

• Compilation tool: xpack windows build tools 4.3.0-1 

• GDB server: Pyocd CMSIS-DAP / J-Link GDB Server CL V7.62c 
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 Project development process 

 Process of building a new project 

Open the Eclipse. Under "File>New", select to create a new C/C++ Project and select 

C Managed Build. 

Figure 1 New Project C/C++Project 

 

Figure 2 C Managed Build 

 

Enter the project name and configure the project type. It is recommended to place the project 

under the Project directory. Configure the compilation chain and select Arm Cross GCC as the 

compilation chain. 
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Figure 3 Configure a Project 

 

If Arm Toolchains of the Eclipse IDE has been correctly configured, the path will be automatically 

selected here. If it has not been configured correctly, click Browse to select the corresponding 

absolute path. 

Figure 4 Set Arm Toolchains Path 

 

 

Click "Finish" until the displayed interface is the view as shown in Figure 5. Then the 

establishment of the Project is completed. 
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Figure 5 Complete Project Establishment 

 

 Project folder and adding a file 

3.2.1 Manual mode 

Figure 6 Add a Folder 

 

Right-click the project folder to create the virtual folder Application. 
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Figure 7 Create a Virtual Folder Application 

 

Similarly, create CMSIS, Board, and StdPeriphDriver folders under this project directory. 

Figure 8 Create CMSIS, Board, and StdPeriphDriver Folders 

 

Select the Application folder, right-click to select the Import option and directly import the file. 
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Figure 9 Import a File 

 

When importing a file, select "File System" as the import mode. In the pop-up file path selection 

dialog box, select the file path to be imported, and check the file to be imported. 

Figure 10 Check the File to be Imported 

 

 

Similarly, import the required files of CMSIS, Board, and StdPeriphDriver folders. 
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Figure 11 Import All Files 

 

3.2.2 "Refresh" method 

In addition to manually importing the folders mentioned above, files and folders can be directly 

placed in the same-level directory as the .cproject. In the Eclipse IDE, right-click the project name 

and select "refresh" to import the folders and files into the project. 

Note: Since the files and folders created by "refresh" are stored in the disk, if a file is deleted from 

the Eclipse IDE, the corresponding file in the disk will also be deleted. 

 Project configuration process 

Right-click the project and select Properties in the pop-up option box. 
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Figure 12 Open Properties Option 

 

3.3.1 Configure Target Processor tab 

The configuration for "C/C++ Build->Settings->Tool Settings->Target Processor" is as follows: 

Select the corresponding core according to the target chip, such as cortex-m3, cortex-m4, 

cortex-m23 or cortex-m33. The chip core used in this example is cortex-m3. 
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Figure 13 Target Processor Configuration 

 

3.3.2 Configure Optimization tab 

In the "C/C++ Build->Settings->Tool Settings->Optimization" option, different optimization levels 

can be configured for the chip, such as -O0, -O1, -O2, -O3, -Os, -Ofast and -Og. 
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Figure 14 Optimization Configuration 

 

3.3.3 Configure GNU Arm Cross C Compiler tab 

Configure “C/C++ Build->Settings->Tool Settings->GNU Arm Cross C Compiler” option. In this 

example, add pre-compile macro: APM32F10X_HD、APM32F103_MINI in 

“Preprocessor->Defined symbols” option. 
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Figure 15 GNU Arm Cross C Compiler Configuration 

 

The header file required by the project is added in the "includes->Include paths" option. In this 

example, the path of the added header file is as follows:  

"${ProjDirPath}/../../Include"  

"${ProjDirPath}/../../../../../Board"  

"${ProjDirPath}/../../../../../Library/APM32F10x_StdPeriphDriver/inc"  

"${ProjDirPath}/../../../../../Library/CMSIS/Include"  

"${ProjDirPath}/../../../../../Library/Device/Geehy/APM32F10x/Include"  

Note: Path addition includes relative path addition and absolute path addition. In this example, 

relative path addition is used. 
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Figure 16 Add the Header File Path Required by the Project 

 

3.3.4 Configure GNU Arm Cross C Linker tab 

Configure "C/C++ Build->Settings->Tool Settings->GNU Arm Cross C Linker" chain option. In this 

example, in “General ->Script files” option, add:  

"${workspace_loc:/${ProjName}/gcc_APM32F10xxE.ld}" 

ld script is a script file used by linker ld, which describes the internal layout of the program, 

defines the symbols for linking, and specifies the start address and size of storage areas such as 

code segment and data segment. The ld script used shall be consistent with the FLASH and RAM 

size of the target chip, and the memory configuration required by the customer. 

Note: For the ld file added in this example, not only can the above relative path addition be used, 

but also the absolute path can be directly added. 

Check the Use newlib-nano and Do not use syscalls of Miscellaneous option to optimize the code 

size. 
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Figure 17 GNU Arm Cross C Linker Configuration 

 

3.3.5 Configure Build Steps tab - Generate bin file 

To generate a bin/hex file, add relevant command in "C/C++ Build->Settings-> Build Steps". 

In this example, add: arm-none-eabi-objcopy -O binary "SysTick_TimeBase.elf" 

"SysTick_TimeBase.bin"; arm-none-eabi-objdump -D "SysTick_TimeBase.elf" > 

"SysTick_TimeBase.dump" 

http://www.geehy.com/


 Document No.: AN1093                                                               

 
www.geehy.com                                                                       Page 19 

Figure 18 Configuration - Generate bin File 

 

 Compile Project 

Click Project and select Build Project to compile the current project.  

Note: Using Build Project will only compile the current project, while using Build All will compile all 

projects in the current workspace. 

Figure 19 Compile a Project 

 

Note: Before compiling, be sure to save the current project. Otherwise, the compiled project may 

be the last saved project, rather than the current modified project. To ensure the correctness of 

the compilation, it is necessary to perform project clean after the modifications, and then compile. 

After compilation, corresponding elf, hex, and bin files will be generated. 
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Figure 20 Compilation Results 

 

 Download and debug the project with J-Link 

3.5.1 Open Debug configuration interface 

In the project, click Run in the menu bar and click Debug Configurations in the pop-up option box 

to enter the Debug configuration interface. 

Figure 21 Enter Debug Configuration Interface 
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Use GDB Server and GDB Client as J-Link configuration option tools. In this example, GDB 

Server is J-Link GDBServerCL, and GDB Client is GDB tool in GCC tool chain. To create a new 

set of J-Link configuration options, double-click GDB SEGGER J-Link Debugging. 

3.5.2 Configure Main tab 

Figure 22 J-Link Main Tab 

 

After a new set of J-Link configuration options is created, the main tab generally will automatically 

add the elf file of the current project by default. If not, click Browse on the right, find the elf file 

generated by the project compilation and manually add it. 

Note: After different chip models are compiled, an elf file will be generated. If there is the need to 

compile multiple chip models, a new set of Debug configuration can be created for different 

models of the chip. 

3.5.3 Configure Debugger tab 

In Debugger tab, the corresponding chip model needs to be filled out in the Device name, and it is 

APM32F103ZE in this example. 

When building an Eclipse environment, if J-Link path has been correctly configured, it will be 

automatically identified here. If the J-Link path configuration fails, the Browse of the Executable 

path can be clicked to select the path of J-Link GDBServerCL. 

Note: The configured J-Link driver must support the chip model filled in. 
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Figure 23 J-Link Debugger Tab 

 

3.5.4 Configure SVD Path tab 

In the SVD Path tab, select the SVD file of the target chip. In this example, the SVD file is 

APM32F103xx.svd, and the default path is: APM32F103_SDK\Packages\SVD 

Figure 24 J-Link SVD Path Tab 
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 Download and debug the project with Geehy-Link 

3.6.1 Configure Pyocd environment 

Install python. The official website download link is Welcome to Python.org. Set the system 

environment variables after downloading. 

Figure 25 Configure System Environment Variables 

 

Open Windows cmd and enter python. If the following information appears, it indicates that 

python has been successfully installed. 

Figure 26 python Is Installed Successfully 

 

Python is installed successfully. Install pyocd and usb driver library. 

1. Exit python and enter exit() in cmd 

2. Install pyocd and enter pipinstall - U pyocd in cmd 

3. Install libsub library and enter pip install - U libusb in cmd 

Enter pyocd in Cmd. If the following information appears, it indicates successful installation. 

Figure 27 pyocd Is Installed Successfully 
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3.6.2 Install pack 

Connect to Geehy-link emulator, and enter pyocd list in cmd. If the following content appears, it 

indicates successful connection. 

Figure 28 Connect Geehy-link Emulator 

 

Download the pack for the corresponding apm32f1 series from the official website of keil 

(https://www.keil.arm.com/devices) or the official website of Geehy (https://geehy.com/MCU). 

Enter pyocd list --target -–pack E:\Geehy.APM32F1xx_DFP.1.1.0.pack in Cmd, and view all chip 

models supported by apm32f1 series pack. 

Figure 29 View apm32f1 Series Pack 

 

When the command is successfully executed, the following information will appear, indicating that 

the information is successfully obtained. 

Figure 30 apm32f103 Chip Model 
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After the emulator is connected to the development board, enter pyocd erase --pack  

E:\Geehy.APM32F1xx_DFP.1.1.0.pack –t apm32f103ze --chip in Cmd to erase the chip. 

Figure 31 apm32f103ze Chip Erase 

 

After the chip is successfully erased, enter pyocd flash --pack 

E:\Geehy.APM32F1xx_DFP.1.1.0.pack --target apm32f103ze + corresponding hex (or elf, bin) 

file in cmd to conduct code burning for the chip. 

Figure 32 apm32f103ze Chip Burning 

 

3.6.3 Open Debug configuration interface 

In the menu bar, click Run and select Debug Configurations in the pop-up selection box to enter 

the Debug configuration interface. 

Use PyOCD and GDB Client as Geehy-Link configuration option tools. In this example, GDB 

Server is PyOCD, and GDB Client is GDB tool in GCC tool chain. To create a new set of 

Geehy-Link configuration options, double-click GDB PyOCD Debugging. 
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3.6.4 Configure Main tab 

Figure 33 Geehy-Link Main Tab 

 

After a new set of Geehy-Link configuration options is created, the main tab generally will 

automatically add the elf file of the current project by default. If not, click Browse on the right, find 

the elf file generated by the project compilation and manually add it. 

Note: After different chip models are compiled, an elf file will be generated. If there is the need to 

compile multiple chip models, a new set of Debug configuration can be created for different 

models of the chip. 

3.6.5 Configure Debugger tab 

When building an Eclipse environment, if PyOCD path has been correctly configured, it will be 

automatically identified here. If the PyOCD path configuration fails, the Browse of the Executable 

path  can be clicked to select the path of PyOCD. In the Debug probe bar, select the used 

CMSIS-DAP emulator. 

Check override target, select the corresponding chip model, and enter the following command in 

Cmd to view the supported models. Here, apm32f103ze is used. 

pyocd list --target --pack E:\Geehy.APM32F1xx_DFP.1.1.0.pack 

Add the pack path in other options, -- pack E:\ Geehy.APM32F1xx_DFP.1.1.0.pack. 
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Figure 34 Geehy-Link Debugger Tab 

 

3.6.6 Configure SVD Path tab 

In the SVD Path tab, select the SVD file required for the chip. In this example, APM32F103xx.svd 

is used, and the default file path of SVD is APM32F10x_SDK\Package\SVD. 

Figure 35 Geehy-Link SVD Path Tab 
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 Debug interface 

If Debug Configurations are completed, click Debug to debug. After the following figure appears, 

click Switch to enter the Debug view. 

Figure 36 Enter Debug View 

 

Figure 37 Debug View 

 

3.7.1 Introduction to toolbars 

: resume to full-speed operation; : suspend; : terminate; : step into; : 

step over; : step out; : reset. 
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3.7.2 Registers window 

Select the Window>Show view>Registers option in the menu bar to view the values of general 

registers. 

Figure 38 Registers Option 
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Figure 39 Registers Window 

 

 

3.7.3 Peripherals window 

In the menu bar, to view the values of peripheral registers, click the Window>Show 

view>Peripherals option. 
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Figure 40 Open Peripherals window 

 

Figure 41 View Peripheral Registers 

 

3.7.4 Memory window 

To view the corresponding memory address of the register or variable, select "Window>Show 

View>Memory" in the menu bar, click the "+" sign above the Memory window to view the 

http://www.geehy.com/


 Document No.: AN1093                                                               

 
www.geehy.com                                                                       Page 32 

corresponding Memory address of the current register or variable. 

Figure 42 Open Memory Window 

 

 

Figure 43 Memory Window 

 

3.7.5 Expressions window 

To view the value of the corresponding variable, select the "Window>Show View>Expressions" in 

the menu bar, click the "+" sign in the Expressions window to add and the variable can be viewed. 
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Figure 44 Expressions Window 

 

Note: In Eclipse, if the program runs at full speed, the value of the corresponding variable cannot 

be updated in real time. The change in the value of the variable can only be viewed when the 

code stops running. 

3.7.6 Disassembly window 

In the Debug mode, click Instruction Stepping Mode to open the disassembly window. 

Figure 45 Open Disassembly Window 

 

In the disassembly window, functions such as single-step debugging of assembly instruction can 

be implemented at the breakpoint. 

Figure 46 Disassembly Window 
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3.7.7 Exit Debug view 

Click the "Stop debugging" button to exit the Debug view. To enter the project view, click the 

"C/C++" in the upper right corner. 

Figure 47 Enter Project View 
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 How to import existing project 

Eclipse can directly import the existing project. In the project view, click File->Import. In the 

pop-up selection view, select General->Exiting Project into Workspace, click "Next", select the 

Eclipse project path, and click finish to import the existing project. 

Figure 48 Import Existing Project 

 

Figure 49 Select Existing Project 
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 How to debug in RAM 

Step 1: Modify the project link script. Shown below is an example of modification. 

/* Specify the memory areas */  

MEMORY  

{  

  FLASH (rx)       : ORIGIN = 0x20000000, LENGTH = 20K  

  RAM (xrw)        : ORIGIN = 0x20005000, LENGTH = 108K  

} 

Step 2: Modify the interrupt vector table and relocate to SRAM. Recompile the project after 

finishing steps 1 and 2. 

Figure 50 Change Interrupt Vector Address 

 

Step 3: Right-click the project, select properties, select Debug Configuration->Startup in the 

pop-up option box, and check RAM application. 

Figure 51 Check RAM application 

 

Step 4: Debug. The following figure shows the Debug view during debugging in RAM. 
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Figure 52 Debug View during debugging in RAM 
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 How to use printf for printing 

 Steps of use 

Step 1: Add the syscall.c file and add the following code to the file to define by adding _write 

function, and redirect usart to __io_putchar function. 

#include "apm32f10x_usart.h"  

 

int _write(int file, char *ptr, int len)  

{  

     int DataIdx;  

     for (DataIdx = 0; DataIdx < len; DataIdx++)  

     {  

        __io_putchar(*ptr++);  

     }  

     return len;  

}  

 

int __io_putchar(int ch)  

{  

     while (USART_ReadStatusFlag(USART1, USART_FLAG_TXBE) == RESET);  

    USART_TxData(USART1, ch);  

     return ch;  

} 

Step 2: Use the printf function to print normally. 

 printf("Runing \r\n"); 

 Configuration of printing floating point data  

In the project view, select File->Properties option, and in C/C++ Build->Settings->Tool 

Settings->GNU Arm Cross C Linker->Miscellaneous, check -u _prinft_float option. 
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Figure 53 Check -u _prinft_float Option 

 

Note: 

1. When using printf printing, add \r\n at the end of the printed content, such as 

printf("Running!\r\n"). 

2. If there is a high requirement for code size, it is not recommended to use printf. If printf is used 

in GCC, the code size will be greatly increased. 
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Table 1 Document Revision History 

Date Revision Changes 

June 13, 2023 1.0 First release 
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Statement 

This manual is formulated and published by Zhuhai Geehy Semiconductor Co., Ltd. (hereinafter referred to 

as "Geehy"). The contents in this manual are protected by laws and regulations of trademark, copyright 

and software copyright. Geehy reserves the right to correct and modify this manual at any time. Please 

read this manual carefully before using the product. Once you use the product, it means that you 

(hereinafter referred to as the "users") have known and accepted all the contents of this manual. Users 

shall use the product in accordance with relevant laws and regulations and the requirements of this 

manual. 

1. Ownership of rights 

This manual can only be used in combination with chip products and software products of corresponding 

models provided by Geehy. Without the prior permission of Geehy, no unit or individual may copy, 

transcribe, modify, edit or disseminate all or part of the contents of this manual for any reason or in any 

form. 

The "Geehy" or "Geehy" words or graphics with "®" or "TM" in this manual are trademarks of Geehy. Other 

product or service names displayed on Geehy products are the property of their respective owners. 

2. No intellectual property license 

Geehy owns all rights, ownership and intellectual property rights involved in this manual. 

Geehy shall not be deemed to grant the license or right of any intellectual property to users explicitly or 

implicitly due to the sale and distribution of Geehy products and this manual. 

If any third party’s products, services or intellectual property are involved in this manual, it shall not be 

deemed that Geehy authorizes users to use the aforesaid third party’s products, services or intellectual 

property, unless otherwise agreed in sales order or sales contract of Geehy. 

3. Version update 

Users can obtain the latest manual of the corresponding products when ordering Geehy products. 

If the contents in this manual are inconsistent with Geehy products, the agreement in Geehy sales order or 

sales contract shall prevail. 

4. Information reliability 

The relevant data in this manual are obtained from batch test by Geehy Laboratory or cooperative 

third-party testing organization. However, clerical errors in correction or errors caused by differences in 

testing environment may occur inevitably. Therefore, users should understand that Geehy does not bear 

any responsibility for such errors that may occur in this manual. The relevant data in this manual are only 
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used to guide users as performance parameter reference and do not constitute Geehy's guarantee for any 

product performance. 

Users shall select appropriate Geehy products according to their own needs, and effectively verify and test 

the applicability of Geehy products to confirm that Geehy products meet their own needs, corresponding 

standards, safety or other reliability requirements. If loses are caused to users due to the user's failure to 

fully verify and test Geehy products, Geehy will not bear any responsibility. 

5. Compliance requirements 

Users shall abide by all applicable local laws and regulations when using this manual and the matching 

Geehy products. Users shall understand that the products may be restricted by the export, re-export or 

other laws of the countries of the product suppliers, Geehy, Geehy distributors and users. Users (on behalf 

of itself, subsidiaries and affiliated enterprises) shall agree and promise to abide by all applicable laws and 

regulations on the export and re-export of Geehy products and/or technologies and direct products. 

6. Disclaimer 

This manual is provided by Geehy "as is". To the extent permitted by applicable laws, Geehy does not 

provide any form of express or implied warranty, including without limitation the warranty of product 

merchantability and applicability of specific purposes. 

Geehy will bear no responsibility for any disputes arising from the subsequent design and use of Geehy 

products by users. 

7. Limitation of liability 

In any case, unless required by applicable laws or agreed in writing, Geehy and/or any third party providing 

this manual "as is" shall not be liable for damages, including any general damages, special direct, indirect 

or collateral damages arising from the use or no use of the information in this manual (including without 

limitation data loss or inaccuracy, or losses suffered by users or third parties). 

8. Scope of application 

The information in this manual replaces the information provided in all previous versions of the manual. 
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